summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2020-06-18 09:31:47 -0700
committerWayne Davison <wayne@opencoder.net>2020-06-18 09:31:47 -0700
commit88c18ef6483fbc7dd89cbab969c1f325b7b55b8e (patch)
tree004f4f958a4f4cbeb4adfc4a063e55956c86be62 /configure.ac
parent7dc9431f60b358620b4a2f8ba105a5732028c545 (diff)
downloadrsync-88c18ef6483fbc7dd89cbab969c1f325b7b55b8e.tar.gz
Make the g++ check more lenient.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 9a0e4d1e..f9a88986 100644
--- a/configure.ac
+++ b/configure.ac
@@ -202,14 +202,17 @@ AC_ARG_ENABLE(simd,
if test x"$enable_simd" = x"yes"; then
# For x86-64 SIMD, g++ is also required
if test x"$build_cpu" = x"x86_64"; then
- if test x"$CXX" = x"g++"; then
- # AC_MSG_RESULT() called below
+ case "$CXX" in
+ *g++)
+ # AC_MSG_RESULT() is called below.
SIMD="$SIMD x86_64"
- else
+ ;;
+ *)
AC_MSG_RESULT(no)
AC_MSG_ERROR(Failed to find g++ for SIMD speedups.
Omit --enable-simd to continue without it.)
- fi
+ ;;
+ esac
fi
fi