summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2020-06-16 09:14:28 -0700
committerWayne Davison <wayne@opencoder.net>2020-06-16 09:14:28 -0700
commit8cd9aa326c878c5707f1e2ce71ea3a3b6c7ae05b (patch)
tree7a7f42673cce281e79d8bb806bb1b8b2b23d0200 /configure.ac
parentcd50745e1c6baa6b44acd0c1003953177e49d065 (diff)
downloadrsync-8cd9aa326c878c5707f1e2ce71ea3a3b6c7ae05b.tar.gz
Fix bug in CXXFLAGS tweak.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index bd43c3f6..baf1a1bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -177,17 +177,14 @@ if test x"$SIMD" != x""; then
AC_MSG_RESULT([yes ($SIMD)])
AC_DEFINE(HAVE_SIMD, 1, [Define to 1 to enable SIMD optimizations])
SIMD=`echo "$SIMD" | sed -e 's/[[^ ]]\+/$(SIMD_&)/g'`
+ # We only use g++ for its target attribute dispatching, disable unneeded bulky features
+ CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti"
else
AC_MSG_RESULT(no)
fi
AC_SUBST(SIMD)
-# We only use g++ for its target attribute dispatching, disable unneeded bulky features
-if test x"$CXXOBJ" != x""; then
- CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti"
-fi
-
# arrgh. libc in some old debian version screwed up the largefile
# stuff, getting byte range locking wrong
AC_CACHE_CHECK([for broken largefile support],rsync_cv_HAVE_BROKEN_LARGEFILE,[