summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2022-08-18 17:33:54 -0700
committerWayne Davison <wayne@opencoder.net>2022-08-18 17:33:54 -0700
commit9a3449a3980421f84ac55498ba565bc112b20d6c (patch)
treeca16b66f2a9ed0b2af30f072209888e60135ceee /configure.ac
parent3258534e994549e07bc65e2ddf11636078f4a8d2 (diff)
downloadrsync-9a3449a3980421f84ac55498ba565bc112b20d6c.tar.gz
Stop enabling -pedantic-errors.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 0 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index d185b2d3..cfc0117f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1071,21 +1071,6 @@ elif test x"$ac_cv_header_popt_h" != x"yes"; then
with_included_popt=yes
fi
-if test x"$GCC" = x"yes"; then
- if test x"$with_included_popt" != x"yes"; then
- # Turn pedantic warnings into errors to ensure an array-init overflow is an error.
- CFLAGS="$CFLAGS -pedantic-errors"
- else
- # Our internal popt code cannot be compiled with pedantic warnings as errors, so try to
- # turn off pedantic warnings (which will not lose the error for array-init overflow).
- # Older gcc versions don't understand -Wno-pedantic, so check if --help=warnings lists
- # -Wpedantic and use that as a flag.
- case `$CC --help=warnings 2>/dev/null | grep Wpedantic` in
- *-Wpedantic*) CFLAGS="$CFLAGS -pedantic-errors -Wno-pedantic" ;;
- esac
- fi
-fi
-
AC_MSG_CHECKING([whether to use included libpopt])
if test x"$with_included_popt" = x"yes"; then
AC_MSG_RESULT($srcdir/popt)