summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2020-07-24 11:38:14 -0700
committerWayne Davison <wayne@opencoder.net>2020-07-24 11:38:14 -0700
commita0a7c9f2e3eee43837a35af6a0d2c16574b5c4b5 (patch)
treeef38cae7fb5a02851c9a2cf36316b0bdfe7909a3 /configure.ac
parenta8f61ba9377d0433b0adfdfbe609c64e6ba01aae (diff)
downloadrsync-a0a7c9f2e3eee43837a35af6a0d2c16574b5c4b5.tar.gz
Enable xattrs on Cygwin.
- Tweak configure.ac to have Cygwin use linux xattrs. - Change CI setup to install attr packages on Cygwin. [buildall]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d9636962..ae6445d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1290,7 +1290,7 @@ if test x"$enable_xattr_support" = x"no"; then
AC_MSG_RESULT(no)
else
case "$host_os" in
- *linux*|*netbsd*)
+ *linux*|*netbsd*|*cygwin*)
AC_MSG_RESULT(Using Linux xattrs)
AC_DEFINE(HAVE_LINUX_XATTRS, 1, [True if you have Linux xattrs (or equivalent)])
AC_DEFINE(SUPPORT_XATTRS, 1)