summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2020-06-20 19:23:07 -0700
committerWayne Davison <wayne@opencoder.net>2020-06-20 19:23:54 -0700
commitb37a136314f250fc837d2836a923ffd441e847ca (patch)
tree003fcea653fcc1e300ceee22b21390d87eb0c8ee /configure.ac
parentc9c8c64506f1475db020435f41d7dd0963e8c892 (diff)
downloadrsync-b37a136314f250fc837d2836a923ffd441e847ca.tar.gz
Get rid of -g option in CXXFLAGS (at least for now).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index c99fe076..53e1a609 100644
--- a/configure.ac
+++ b/configure.ac
@@ -227,7 +227,7 @@ inline void more_testing(char* buf, int len)
AC_LANG(C)
if test x"$CXX_OK" = x"yes"; then
# AC_MSG_RESULT() is called below.
- SIMD="$SIMD x86_64"
+ SIMD="x86_64"
elif test x"$enable_simd" = x"yes"; then
AC_MSG_RESULT(error)
AC_MSG_ERROR(The SIMD compilation test failed.
@@ -241,10 +241,11 @@ Omit --enable-simd to continue without it.)
fi
if test x"$SIMD" != x""; then
- SIMD=`echo "$SIMD" | sed 's/^ *//'`
AC_MSG_RESULT([yes ($SIMD)])
AC_DEFINE(HAVE_SIMD, 1, [Define to 1 to enable SIMD optimizations])
- SIMD=`echo '$(SIMD_'"$SIMD)" | sed 's/ /) $(SIMD_/g'`
+ SIMD='$(SIMD_'"$SIMD)"
+ # Clag is crashing with -g -O2, so we'll get rid of -g (just for the one file).
+ CXXFLAGS=`echo "'$CXXFLAGS'" | sed 's/-g //'`
# We only use c++ for its target attribute dispatching, disable unneeded bulky features
CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti"
else