summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2020-06-21 22:34:32 -0700
committerWayne Davison <wayne@opencoder.net>2020-06-21 22:34:32 -0700
commitd8d2d71663c93cf72f698842074f66f7d548c0da (patch)
tree3c9410ec3d6ee2fe7faf1cee045957bf5a0ef92c /configure.ac
parent6a9adabfbbebf682c173c1ee1c9322a94cf096be (diff)
downloadrsync-d8d2d71663c93cf72f698842074f66f7d548c0da.tar.gz
Get the g++ version to see if it is really clang.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 135a7e85..df0d8903 100644
--- a/configure.ac
+++ b/configure.ac
@@ -250,7 +250,9 @@ if test x"$SIMD" != x""; then
SIMD='$(SIMD_'"$SIMD)"
# We only use c++ for its target attribute dispatching, disable unneeded bulky features
CXXFLAGS="$CXXFLAGS -fno-exceptions -fno-rtti"
- case "$CXX" in
+ # Apple often has "g++" as a symlink for clang. Try to find out the truth.
+ CXX_VERSION=`$CXX --version 2>/dev/null | head -n 2`
+ case "$CXX_VERSION" in
*clang*) CXXFLAGS="$CXXFLAGS -fno-slp-vectorize" ;; # avoid a performance hit
esac
else