summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2020-06-21 09:06:53 -0700
committerWayne Davison <wayne@opencoder.net>2020-06-21 09:06:59 -0700
commitf86ceb5539c82771b83db1e06ef3b710b1f7e201 (patch)
treec4ae3bb8dd5ff233429c81a3c57eea325aa22a61 /configure.ac
parentdfa34b479270de6a7db2737d1f232344199292f6 (diff)
downloadrsync-f86ceb5539c82771b83db1e06ef3b710b1f7e201.tar.gz
Give more_testing() a default target.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5e58c7d7..19b12851 100644
--- a/configure.ac
+++ b/configure.ac
@@ -217,6 +217,7 @@ __attribute__ ((target("sse2"))) int test_sse2(int x) { return x; }
__attribute__ ((target("avx2"))) int test_avx2(int x) { return x; }
typedef long long __m128i_u __attribute__((__vector_size__(16), __may_alias__, __aligned__(1)));
typedef long long __m256i_u __attribute__((__vector_size__(32), __may_alias__, __aligned__(1)));
+__attribute__ ((target("default"))) void more_testing(char* buf, int len) { }
__attribute__ ((target("ssse3"))) void more_testing(char* buf, int len)
{
int i;