summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorWayne Davison <wayne@opencoder.net>2020-05-25 11:50:44 -0700
committerWayne Davison <wayne@opencoder.net>2020-05-25 11:50:44 -0700
commitfc265c5a927466172dc01593be86becfc46913b8 (patch)
tree96160d8b9d2603fc952050b8d8c4b65fce79435d /configure.ac
parentd999efe6e56bda37f8b7109fd0a146c1a4c290be (diff)
downloadrsync-fc265c5a927466172dc01593be86becfc46913b8.tar.gz
A couple minor configure.ac tweaks.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index e22e17e9..cbf93056 100644
--- a/configure.ac
+++ b/configure.ac
@@ -391,8 +391,7 @@ AH_TEMPLATE([USE_OPENSSL],
[Undefine if you do not want to use openssl crypto library. By default this is defined.])
if test x"$enable_openssl" != x"no" && test x"$ac_cv_header_openssl_md4_h" = x"yes" && test x"$ac_cv_header_openssl_md5_h" = x"yes"; then
AC_MSG_RESULT(yes)
- AC_SEARCH_LIBS(MD5_Init, crypto)
- AC_DEFINE(USE_OPENSSL)
+ AC_SEARCH_LIBS(MD5_Init, crypto, [AC_DEFINE(USE_OPENSSL)])
else
AC_MSG_RESULT(no)
fi
@@ -404,8 +403,7 @@ AH_TEMPLATE([SUPPORT_XXHASH],
[Undefine if you do not want xxhash checksums. By default this is defined.])
if test x"$enable_xxhash" != x"no" && test x"$ac_cv_header_xxhash_h" = x"yes"; then
AC_MSG_RESULT(yes)
- AC_SEARCH_LIBS(XXH64_createState, xxhash)
- AC_DEFINE(SUPPORT_XXHASH)
+ AC_SEARCH_LIBS(XXH64_createState, xxhash, [AC_DEFINE(SUPPORT_XXHASH)])
else
AC_MSG_RESULT(no)
fi