summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Wu <XrXr@users.noreply.github.com>2022-11-08 15:29:30 -0500
committerGitHub <noreply@github.com>2022-11-08 15:29:30 -0500
commit1466682a23ce0d7bf1f30d8b9627b4597c037e4d (patch)
treeaa65e335c1fb45a6f9a201d48897e4ac44dd5518 /configure.ac
parent1a65ab20cb6519ab3d4e58141cfd812eaea5f7e0 (diff)
downloadruby-1466682a23ce0d7bf1f30d8b9627b4597c037e4d.tar.gz
YJIT: Improve checking message for rustc version (#6693)
Preivously we didn't have a "checking ...." line for this check and when rustc was too old, we would dump the error message to the console like: checking for rustc... rustc error: there is no argument named `x` --> <anon>:1:33 | 1 | fn main() { let x = 1; format!("{x}"); } | ^^^ error: aborting due to previous error `configure` checks usually don't do this and this might be confusing. With this commit it now says something like: checking whether rustc is new enough for YJIT... no
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 45b9a3a631..59a6508ad8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3738,9 +3738,11 @@ AC_CHECK_PROG(RUSTC, [rustc], [rustc], [no]) dnl no ac_tool_prefix
dnl check if rustc is recent enough to build YJIT (rustc >= 1.58.0)
YJIT_RUSTC_OK=no
AS_IF([test "$RUSTC" != "no"],
- AS_IF([echo "fn main() { let x = 1; format!(\"{x}\"); }" | $RUSTC - --emit asm=/dev/null],
+ AC_MSG_CHECKING([whether ${RUSTC} is new enough for YJIT])
+ AS_IF([echo "fn main() { let x = 1; format!(\"{x}\"); }" | $RUSTC - --emit asm=/dev/null 2>/dev/null],
[YJIT_RUSTC_OK=yes]
)
+ AC_MSG_RESULT($YJIT_RUSTC_OK)
)
dnl check if we can build YJIT on this target platform