summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTakashi Kokubun <takashikkbn@gmail.com>2022-12-19 07:26:21 -0800
committerGitHub <noreply@github.com>2022-12-19 10:26:21 -0500
commit1482f0649e303c8bf11281268d3e1e6e2370c093 (patch)
tree9de99cd905185feb3344b50890c5742a07a80097 /configure.ac
parentbcdc9cf1590caeda83c4e8f90f27a4a80b152e08 (diff)
downloadruby-1482f0649e303c8bf11281268d3e1e6e2370c093.tar.gz
YJIT: Improve the description about --enable-yjit (#6947)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 69f57d161c..7603f01253 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3791,7 +3791,7 @@ AS_IF([test "$cross_compiling" = no],
dnl build YJIT in release mode if rustc >= 1.58.0 is present and we are on a supported platform
AC_ARG_ENABLE(yjit,
AS_HELP_STRING([--enable-yjit],
- [enable in-process JIT compiler that requires Rust build tools [default=no]]),
+ [enable in-process JIT compiler that requires Rust build tools. enabled by default on supported platforms if rustc 1.58.0+ is available]),
[YJIT_SUPPORT=$enableval],
[AS_CASE(["$enable_jit_support:$YJIT_TARGET_OK:$YJIT_RUSTC_OK"],
[yes:yes:yes|:yes:yes], [