summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSergey Fedorov <vital.had@gmail.com>2022-05-22 11:02:03 +0800
committerGitHub <noreply@github.com>2022-05-22 15:02:03 +1200
commit539459abda3f4e086ca060620dee2586ebfed873 (patch)
treeb9a4f71f8a74bafb1b7afa81245688b553f255e4 /configure.ac
parent84257244cd67e40daed274c01ff0a6929e1a2b67 (diff)
downloadruby-539459abda3f4e086ca060620dee2586ebfed873.tar.gz
Ruby31: add support for Darwin ppc/ppc64 (#5927)
* add coroutines for ppc & ppc64 * fix universal coroutine to include ppc & ppc64 * add powerpc*-darwin to configure.ac * fix thread_pthread for older systems
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 53aa21025e..9e5db655e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1866,7 +1866,7 @@ AS_IF([test $rb_cv_stack_end_address != no], [
dnl Checks for library functions.
AC_TYPE_GETGROUPS
AS_CASE(["${target_cpu}-${target_os}:${target_archs}"],
-[powerpc-darwin*], [
+[powerpc*-darwin*], [
AC_LIBSOURCES(alloca.c)
AC_SUBST([ALLOCA], [\${LIBOBJDIR}alloca.${ac_objext}])
AC_DEFINE(C_ALLOCA)
@@ -2546,6 +2546,12 @@ AS_CASE([$coroutine_type], [yes|''], [
[arm64-darwin*], [
coroutine_type=arm64
],
+ [powerpc-darwin*], [
+ coroutine_type=ppc
+ ],
+ [powerpc64-darwin*], [
+ coroutine_type=ppc64
+ ],
[x*64-linux*], [
AS_CASE(["$ac_cv_sizeof_voidp"],
[8], [ coroutine_type=amd64 ],