summaryrefslogtreecommitdiff
path: root/yjit/Cargo.toml
diff options
context:
space:
mode:
authorTakashi Kokubun <takashikkbn@gmail.com>2022-11-13 09:54:41 -0800
committerGitHub <noreply@github.com>2022-11-13 12:54:41 -0500
commit6246788bc47b5d28e3c612479a2986d84f2aa589 (patch)
tree2a09d2bf3158d0864eb0d4d459c82c645ce84e7c /yjit/Cargo.toml
parentbc8ba244b8524c8537eda4ca79f880312c8f4528 (diff)
downloadruby-6246788bc47b5d28e3c612479a2986d84f2aa589.tar.gz
YJIT: Instrument global allocations on stats build (#6712)
* YJIT: Instrument global allocations on stats build * Just use GLOVAL_ALLOCATOR.stats()
Diffstat (limited to 'yjit/Cargo.toml')
-rw-r--r--yjit/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/yjit/Cargo.toml b/yjit/Cargo.toml
index 858751b1f6..d7d96d5799 100644
--- a/yjit/Cargo.toml
+++ b/yjit/Cargo.toml
@@ -16,12 +16,13 @@ crate-type = ["staticlib"]
# No required dependencies to simplify build process. TODO: Link to yet to be
# written rationale. Optional For development and testing purposes
capstone = { version = "0.10.0", optional = true }
+stats_alloc = { version = "0.1.10", optional = true }
[features]
# NOTE: Development builds select a set of these via configure.ac
# For debugging, `make V=1` shows exact cargo invocation.
disasm = ["capstone"]
-stats = []
+stats = ["stats_alloc"]
[profile.dev]
opt-level = 0