summaryrefslogtreecommitdiff
path: root/yjit/Cargo.toml
diff options
context:
space:
mode:
authorJohn Hawthorn <john@hawthorn.email>2022-07-06 22:14:25 -0700
committerJohn Hawthorn <john@hawthorn.email>2022-07-29 16:32:14 -0700
commitfbd24793cb7be2429edafcf11d7dd4a7d11f5c95 (patch)
tree737c3b35c5b52523e6598006716477f36f9cdc38 /yjit/Cargo.toml
parent53175643ef826775d0a51fc48fdd79a4cf01dc70 (diff)
downloadruby-fbd24793cb7be2429edafcf11d7dd4a7d11f5c95.tar.gz
Add --enable-yjit=stats configure option
Diffstat (limited to 'yjit/Cargo.toml')
-rw-r--r--yjit/Cargo.toml3
1 files changed, 3 insertions, 0 deletions
diff --git a/yjit/Cargo.toml b/yjit/Cargo.toml
index a5208049cb..c7ff31ec2c 100644
--- a/yjit/Cargo.toml
+++ b/yjit/Cargo.toml
@@ -30,6 +30,9 @@ debug = true
debug-assertions = true
overflow-checks = true
+[profile.stats]
+inherits = "release"
+
[profile.release]
# NOTE: --enable-yjit builds use `rustc` without going through Cargo. You
# might want to update the `rustc` invocation if you change this profile.