summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorGregor Peach <gregorpeach@gmail.com>2020-01-04 15:40:36 -0800
committerGregor Peach <gregorpeach@gmail.com>2020-01-30 15:40:14 -0500
commit0d52c562db18e85cf53078c9ddb40abe469a4aab (patch)
tree69a70c7774210ef35f7954299ea921aeb0329a54 /Cargo.toml
parent760ce94c69ca510d44087291c311296f6d9ccdf5 (diff)
downloadrust-0d52c562db18e85cf53078c9ddb40abe469a4aab.tar.gz
Change opt-level from 2 back to 3
In Cargo.toml, the opt-level for `release` and `bench` was overridden to be 2. This was to work around a problem with LLVM 7. However, rust no longer uses LLVM 7, so this is no longer needed. This creates a small compile time regression in MIR constant eval, so I've added a #[inline(always)] on the `step` function used in const eval Also creates a binary size increase in wasm-stringify-ints-small, so I've bumped the limit there.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 0 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a242f090fbc..8c3c858de1d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -30,13 +30,6 @@ exclude = [
"obj",
]
-# Curiously, LLVM 7.0 will segfault if compiled with opt-level=3
-# See issue https://github.com/rust-lang/rust/issues/52378
-[profile.release]
-opt-level = 2
-[profile.bench]
-opt-level = 2
-
# These options are controlled from our rustc wrapper script, so turn them off
# here and have them controlled elsewhere.
[profile.dev]