summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJoshua Nelson <jyn514@gmail.com>2021-04-02 04:11:46 -0400
committerJoshua Nelson <jyn514@gmail.com>2021-04-12 09:39:04 -0400
commit1b0b7e95be5f0da032ddd35226792ca469c21684 (patch)
tree99ede4bb5330bba0d696b4af2db778f447d07c12 /Cargo.toml
parentb1b0a1597c40b55b81e5b95ea5fc825a1287b2bb (diff)
downloadrust-1b0b7e95be5f0da032ddd35226792ca469c21684.tar.gz
Update stdarch submodule (to before it switched to const generics)
This also includes a cherry-pick of https://github.com/rust-lang/stdarch/commit/ec1461905b421cf0c56adeebb49bbf55bb33fd17 and https://github.com/rust-lang/stdarch/pull/1108 to fix a build failure. It also adds a re-export of various macros to the crate root of libstd - previously they would show up automatically because std_detect was defined in the same crate.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index f961d3e9b97..e630be47c46 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -45,6 +45,8 @@ exclude = [
# not all `Cargo.toml` files are available, so we exclude the `x` binary,
# so it can be invoked before the current checkout is set up.
"src/tools/x",
+ # stdarch has its own Cargo workspace
+ "library/stdarch",
]
[profile.release.package.compiler_builtins]