summaryrefslogtreecommitdiff
path: root/compiler/rustc_query_impl
Commit message (Expand)AuthorAgeFilesLines
...
* | don't clone Copy typesMatthias Krüger2022-12-181-1/+1
|/
* Auto merge of #104940 - cjgillot:query-feed-simple, r=oli-obkbors2022-11-301-1/+14
|\
| * Sanity check computed value for feeable queries.Camille GILLOT2022-11-291-0/+13
| * Make verbose query description more useful.Camille GILLOT2022-11-291-1/+1
* | Make inferred_outlives_crate return ClauseSantiago Pastorino2022-11-291-0/+6
|/
* Rollup merge of #104675 - SarthakSingh31:issue-101666, r=jyn514Matthias Krüger2022-11-261-2/+1
|\
| * Unsupported query error now specifies if its unsupported for local or externa...Sarthak Singh2022-11-241-2/+1
* | Add empty ConstKind::Abstractkadmin2022-11-251-6/+0
|/
* Auto merge of #103808 - cjgillot:vec-cache, r=TaKO8Kibors2022-11-243-588/+2
|\
| * Move keys module.Camille GILLOT2022-11-013-588/+2
* | Make AbsoluteBytePos a u64.Camille GILLOT2022-11-081-3/+2
* | Remove one lifetime from `QueryKeyStringBuilder`Nilstrieb2022-11-061-36/+15
* | Merge `QueryDescription` into `QueryConfig`Nilstrieb2022-11-053-18/+15
* | rustdoc: use ThinVec for cleaned genericsMichael Howell2022-11-021-1/+1
|/
* Introduce UnordMap, UnordSet, and UnordBag (see MCP 533)Michael Woerister2022-10-271-2/+3
* Introduce deduced parameter attributes, and use them for deducing `readonly` onPatrick Walton2022-10-211-0/+1
* Remove the `describe` method from the `QueryDescription` traitnils2022-10-141-8/+4
* Get rid of `rustc_query_description!`Nilstrieb2022-10-142-11/+9
* Rewrite representabilityCameron Steffen2022-10-072-4/+14
* Remove `-Ztime` option.Nicholas Nethercote2022-10-061-1/+1
* Correct Key impl for HirId.Camille GILLOT2022-10-011-2/+2
* Compute `lint_levels` by definitionDeadbeef2022-10-011-1/+17
* Auto merge of #101785 - jyn514:query-struct-fn-ptrs, r=cjgillotbors2022-09-263-56/+95
|\
| * Use function pointers instead of macro-unrolled loops in rustc_query_implJoshua Nelson2022-09-253-56/+95
* | Move the `codegen_unit` debug assert from `rustc_query_system` to `query_impl`Joshua Nelson2022-09-251-0/+18
|/
* separate definitions and `HIR` ownersTakayuki Maeda2022-09-241-0/+14
* Auto merge of #102064 - cjgillot:revert, r=Mark-Simulacrumbors2022-09-241-17/+0
|\
| * Revert "Auto merge of #101620 - cjgillot:compute_lint_levels_by_def, r=oli-obk"Camille GILLOT2022-09-221-17/+0
* | rename Unevaluated to UnevaluatedConstb-naber2022-09-231-1/+1
* | introduce mir::Unevaluatedb-naber2022-09-221-1/+1
|/
* Rollup merge of #101801 - SparrowLii:query_depth_note, r=estebankMatthias Krüger2022-09-171-2/+27
|\
| * correct span, add help message and add UI test when query depth overflowsSparrowLii2022-09-151-1/+26
| * add note for `layout_of` when query depth overflowsSparrowLii2022-09-151-1/+1
* | Rollup merge of #101787 - compiler-errors:cache-rpitit, r=petrochenkovDylan DPC2022-09-161-0/+6
|\ \
| * | cache collect_trait_impl_trait_tysMichael Goulet2022-09-141-0/+6
* | | Auto merge of #101173 - jyn514:simplify-macro-arguments, r=cjgillotbors2022-09-152-8/+20
|\ \ \ | |_|/ |/| |
| * | Get rid of the emitted `rustc_query_names` and `rustc_cached_queries` macroJoshua Nelson2022-09-062-9/+21
| * | Support doc-comments in `define_dep_nodes`Joshua Nelson2022-09-061-2/+2
| * | Further simplify the macros generated by `rustc_queries`Joshua Nelson2022-09-061-2/+2
* | | Correct Key impl for HirId.Camille GILLOT2022-09-141-2/+2
* | | Compute `lint_levels` by definitionDeadbeef2022-09-141-0/+17
* | | Auto merge of #101307 - jyn514:simplify-storage, r=cjgillotbors2022-09-142-3/+26
|\ \ \ | |_|/ |/| |
| * | Remove unnecessary `TRY_LOAD_FROM_DISK` constantJoshua Nelson2022-09-092-5/+1
| * | Move `TRY_LOAD_FROM_DISK` out of `rustc_queries` to `rustc_query_impl`Joshua Nelson2022-09-091-0/+3
| * | Remove `cache_on_disk` from `QueryVTable`Joshua Nelson2022-09-091-2/+1
| * | Don't create a new `try_load_from_disk` closure for each queryJoshua Nelson2022-09-092-1/+26
* | | Rollup merge of #101635 - jyn514:queries-new-derived, r=cjgillotDylan DPC2022-09-101-15/+20
|\ \ \ | |/ / |/| |
| * | Move `Queries::new` out of the macroJoshua Nelson2022-09-061-15/+20
| |/
* | Make `HandleCycleError` an enum instead of a macro-generated closureJoshua Nelson2022-09-063-81/+11
|/
* Don't create two new closures for each queryJoshua Nelson2022-09-011-30/+21