summaryrefslogtreecommitdiff
path: root/rpm/SPECS
diff options
context:
space:
mode:
authorMagnus <mfeuer@jaguarlandrover.com>2014-09-14 16:45:13 -0700
committerMagnus <mfeuer@jaguarlandrover.com>2014-09-14 16:45:13 -0700
commitf0f53cf69a83980af80c664b304493dd90b0f006 (patch)
treea44c6ef894ba2d9f10f85b5b32726ea996c3fbc8 /rpm/SPECS
parent7b13e3a6e0b330c5e991a73fd415cebd4f11fb27 (diff)
downloadrvi_core-f0f53cf69a83980af80c664b304493dd90b0f006.tar.gz
Now builds RPM files correctly. Still need to %install rpm/rvi start/stop script in /etc/init.d
Signed-off-by: Magnus <mfeuer@jaguarlandrover.com>
Diffstat (limited to 'rpm/SPECS')
-rw-r--r--rpm/SPECS/.gitignore4
-rw-r--r--rpm/SPECS/rvi-0.2.spec40
2 files changed, 44 insertions, 0 deletions
diff --git a/rpm/SPECS/.gitignore b/rpm/SPECS/.gitignore
new file mode 100644
index 0000000..5e7d273
--- /dev/null
+++ b/rpm/SPECS/.gitignore
@@ -0,0 +1,4 @@
+# Ignore everything in this directory
+*
+# Except this file
+!.gitignore
diff --git a/rpm/SPECS/rvi-0.2.spec b/rpm/SPECS/rvi-0.2.spec
new file mode 100644
index 0000000..2e7d335
--- /dev/null
+++ b/rpm/SPECS/rvi-0.2.spec
@@ -0,0 +1,40 @@
+Summary: Remote Vehicle Interaction Node
+Name: rvi
+Version: 0.2
+Release: 1
+# Copyright: Jaguar Land Rover -
+License: Mozilla Public License v2
+Vendor: Jaguar Land Rover
+Group: Applications/System
+Source: http://content.linuxfoundation.org/auto/downloads/rvi/rvi-0.2.tgz
+Buildroot: /var/tmp/%{name}-buildroot
+
+# Requires:
+
+%description
+The RVI project sets up a P2P network allowing services on multiple
+nodes to access each other through a number of different protocols
+and data channels. The entire system is designed to be adapted
+and rewritten to fullfil the requirements of the target production
+environment.
+
+#
+%prep
+%setup -c rvi-$RPM_PACKAGE_VERSION
+
+%build
+make deps
+make compile
+./setup_rvi_node.sh -n rvi-$RPM_PACKAGE_VERSION -c rvi_sample.config
+
+%install
+rm -rf $RPM_BUILD_ROOT
+mkdir -p $RPM_BUILD_ROOT/opt/rvi-$RPM_PACKAGE_VERSION
+cp -ar * $RPM_BUILD_ROOT/opt/rvi-$RPM_PACKAGE_VERSION
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root)
+/opt/rvi-0.2