summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMurray Cumming <murrayc@murrayc.com>2012-10-19 13:44:37 +0200
committerMurray Cumming <murrayc@murrayc.com>2012-10-22 12:42:41 +0200
commit53afa65e0193da0ee79e8f5b0b973b47cf13e2f8 (patch)
treecbad050cd334366436708800c1e87125f7a11459 /configure.ac
parent51f60a45971b9b4a03a997b5e3f33cc912c49601 (diff)
downloadrygel-53afa65e0193da0ee79e8f5b0b973b47cf13e2f8.tar.gz
Add an example server plugin
* configure.ac: Add an --enable-example-plugins option. * autogen.sh: Add --enable-example-plugins * examples/: Add an example server plugin implemented in Vala. * src/librygel-core/rygel-plugin.vala: * src/librygel-core/rygel-plugin.vala: Document the name, title, and description parameters used by the example.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a3e24c4e..5c5db75f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,6 +106,12 @@ AS_IF([test "x$with_media_engine" = "xgstreamer"],
RYGEL_DISABLE_PLUGIN([media-export])
RYGEL_DISABLE_PLUGIN([gst-launch])
])
+
+dnl Example plugins:
+AC_ARG_ENABLE([example-plugins],
+ AS_HELP_STRING([--enable-example-plugins],[enable example plugins]),,
+ enable_example_plugins=no)
+AM_CONDITIONAL([BUILD_EXAMPLE_PLUGINS], [test "x$[]enable_example_plugins" = "xyes"])
dnl Explicitly add stamp files for targets that are not plugins
RYGEL_ADD_STAMP([src/librygel-core/librygel_core_2_0_la_vala.stamp])
@@ -303,6 +309,8 @@ rygel-server-2.0.pc
rygel-renderer-gst-2.0.pc
tests/Makefile
examples/Makefile
+examples/server-plugins/Makefile
+examples/server-plugins/vala/Makefile
])
AC_OUTPUT
@@ -321,6 +329,7 @@ echo "
preferences ui: ${HAVE_GTK}
Media Engine: ${with_media_engine}
Plugins:
+ examples: ${enable_example_plugins}
test: ${enable_test_plugin}
tracker: ${enable_tracker_plugin}
mediathek: ${enable_mediathek_plugin}