summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJens Georg <mail@jensge.org>2020-02-13 22:08:36 +0100
committerJens Georg <mail@jensge.org>2020-02-23 12:37:36 +0100
commit725c45a381c6b3289179eca054be5a7feb03dcd7 (patch)
tree4c0899519ab48c48f33a8de260cb1f34d7b210e7 /meson.build
parentb3d7d462c75ca867f325525258966fd651de6b1c (diff)
downloadrygel-725c45a381c6b3289179eca054be5a7feb03dcd7.tar.gz
build: Add fatal_warnings configure option
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3f8671cf..b7034cd9 100644
--- a/meson.build
+++ b/meson.build
@@ -64,6 +64,10 @@ config_include = include_directories('.')
add_global_arguments(['-include','config.h'], language : 'c')
+if get_option('fatal_warnings')
+ add_global_arguments(['--fatal-warnings'], language : 'vala')
+endif
+
valadoc = find_program('valadoc', required : false)
gtkdoc = dependency('gtk-doc', required : false)