summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2013-09-16 11:11:15 +0300
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2013-09-16 12:17:36 +0300
commitc0a74816996faa8fa5fd87a80570936910f1f165 (patch)
tree1a6f559c92f8d736b860bf6a074ff132ce56bf59 /configure.ac
parent4210339058f56c504a553cb77b853e5597cfaf7c (diff)
downloadsbc-c0a74816996faa8fa5fd87a80570936910f1f165.tar.gz
build: Add configure option --disable-high-precision
This enables high precision using 64 bits accumulators by default which can be disabled with --disable-high-precision.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c052616..5f994d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -58,4 +58,12 @@ if (test "${enable_tester}" != "no"); then
fi
AM_CONDITIONAL(TESTER, test "${enable_tester}" != "no")
+AC_ARG_ENABLE(high-precision, AC_HELP_STRING([--disable-high-precision],
+ [disable high precision support]),
+ [enable_high_precision=${enableval}])
+if (test "${enable_high_precision}" != "no"); then
+ AC_DEFINE(SBC_HIGH_PRECISION, 1,
+ [Define to 1 to enable high precision build of SBC encoder])
+fi
+
AC_OUTPUT(Makefile sbc/sbc.pc)