summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 5f994d1..3a96196 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,6 +44,14 @@ AC_ARG_ENABLE(pie, AC_HELP_STRING([--enable-pie],
fi
])
+AC_ARG_ENABLE(high-precision, AC_HELP_STRING([--enable-high-precision],
+ [enable SBC high precision support]),
+ [enable_high_precision=${enableval}])
+if (test "${enable_high_precision}" = "yes"); then
+ AC_DEFINE(SBC_HIGH_PRECISION, 1,
+ [Define to 1 to enable high precision build of SBC encoder])
+fi
+
AC_ARG_ENABLE(tools, AC_HELP_STRING([--disable-tools],
[disable SBC tools]), [enable_tools=${enableval}])
AM_CONDITIONAL(TOOLS, test "${enable_tools}" != "no")
@@ -58,12 +66,4 @@ if (test "${enable_tester}" != "no"); then
fi
AM_CONDITIONAL(TESTER, test "${enable_tester}" != "no")
-AC_ARG_ENABLE(high-precision, AC_HELP_STRING([--disable-high-precision],
- [disable high precision support]),
- [enable_high_precision=${enableval}])
-if (test "${enable_high_precision}" != "no"); then
- AC_DEFINE(SBC_HIGH_PRECISION, 1,
- [Define to 1 to enable high precision build of SBC encoder])
-fi
-
AC_OUTPUT(Makefile sbc/sbc.pc)