summaryrefslogtreecommitdiff
path: root/SConstruct
diff options
context:
space:
mode:
authorMats Wichmann <mats@linux.com>2019-02-06 09:10:21 -0700
committerMats Wichmann <mats@linux.com>2019-02-06 09:10:21 -0700
commitf04b4313cd4b96bdb01ff77294ca24ee9d9c0ebb (patch)
tree0a9641ac5903be06191886c478de6d6b149833f6 /SConstruct
parent6666adc9457f109ec25c9cd687f9eb0384392c73 (diff)
downloadscons-git-f04b4313cd4b96bdb01ff77294ca24ee9d9c0ebb.tar.gz
Fix problem where API doc gen misses some files
In doc/SConscript, the function in bootstrap.py to parse a manifest was called with an scons path (#src/engine) but bootstrap does not run in an scons context, it is run via subprocess.Popen. Preprocess the path. Along the way, change the function to open the file itself instead of being passed a list already read from the file, update the comment, and clean some whitespace issues. Signed-off-by: Mats Wichmann <mats@linux.com>
Diffstat (limited to 'SConstruct')
-rw-r--r--SConstruct8
1 files changed, 3 insertions, 5 deletions
diff --git a/SConstruct b/SConstruct
index 3d93d1e6b..8f7ceafc0 100644
--- a/SConstruct
+++ b/SConstruct
@@ -335,7 +335,7 @@ python_scons = {
'debian_deps' : [
'debian/changelog',
'debian/compat',
- 'debian/control',
+ 'debian/control',
'debian/copyright',
'debian/dirs',
'debian/docs',
@@ -499,8 +499,7 @@ for p in [ scons ]:
# destination files.
#
manifest_in = File(os.path.join(src, 'MANIFEST.in')).rstr()
- manifest_in_lines = open(manifest_in).readlines()
- src_files = bootstrap.parseManifestLines(src, manifest_in_lines)
+ src_files = bootstrap.parseManifestLines(src, manifest_in)
raw_files = src_files[:]
dst_files = src_files[:]
@@ -520,12 +519,11 @@ for p in [ scons ]:
MANIFEST_in = File(os.path.join(src, ssubdir, 'MANIFEST.in')).rstr()
MANIFEST_in_list.append(MANIFEST_in)
- files = bootstrap.parseManifestLines(os.path.join(src, ssubdir), open(MANIFEST_in).readlines())
+ files = bootstrap.parseManifestLines(os.path.join(src, ssubdir), MANIFEST_in)
raw_files.extend(files)
src_files.extend([os.path.join(ssubdir, x) for x in files])
-
files = [os.path.join(isubdir, x) for x in files]
dst_files.extend(files)
for k, f in sp['filemap'].items():