summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorManish Vachharajani <manishv@unbounded.systems>2017-03-22 12:33:18 -0600
committerManish Vachharajani <manishv@unbounded.systems>2017-03-22 12:33:18 -0600
commit192965c27b04e876904cffee60fb5edb3f1e92fb (patch)
tree7db6f0e5b2a947dee7b20f12287d9c102ddb862a /debian/rules
parent2e593b9d2b58f34ef34b1b56bb13945849950112 (diff)
downloadscons-192965c27b04e876904cffee60fb5edb3f1e92fb.tar.gz
Make bootstrap.py work again and work on Ubuntu Xenial.
Added *cxx.py files to Manifest.in, removed VCS modules that were deleted, and updated debian package build information.
Diffstat (limited to 'debian/rules')
-rw-r--r--debian/rules6
1 files changed, 2 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 1effa02e..9d83723a 100644
--- a/debian/rules
+++ b/debian/rules
@@ -15,8 +15,6 @@ PYTHON=$(PYTHON_PATH)$(PYTHON_VERSION)
#export DH_VERBOSE=1
# This is the debhelper compatability version to use.
-export DH_COMPAT=2
-
configure: configure-stamp
configure-stamp:
dh_testdir
@@ -41,7 +39,7 @@ clean:
install: build
dh_testdir
dh_testroot
- dh_clean -k
+ dh_prep
dh_installdirs
# Add here commands to install the package into debian/scons.
@@ -106,7 +104,7 @@ binary-indep: build install
dh_shlibdeps
dh_gencontrol
dh_md5sums
- DH_COMPAT=$(DH_COMPAT) dh_builddeb $(BUILDDEB_OPTIONS)
+ dh_builddeb $(BUILDDEB_OPTIONS)
# Build architecture-dependent files here.
binary-arch: build install