summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGary Oberbrunner <garyo@oberbrunner.com>2012-08-12 23:25:31 -0400
committerGary Oberbrunner <garyo@oberbrunner.com>2012-08-12 23:25:31 -0400
commitc6b838a9c8dd8b911637cacbace03419f89001fa (patch)
treed623ba107f87296c3b7101d5d798e767125ba2f4 /debian/rules
parentfca1fdbf19a60e04eb1909d7b6af5130b3319c9f (diff)
downloadscons-c6b838a9c8dd8b911637cacbace03419f89001fa.tar.gz
Fix Debian build process.
Each release needs to update debian/changelog, and it needs to be in a particular format since the deb build process reads and parses it to get the version number in the .deb. Also fixed a few other deb-build-related errors.
Diffstat (limited to 'debian/rules')
-rw-r--r--debian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 1eaf4de5..1effa02e 100644
--- a/debian/rules
+++ b/debian/rules
@@ -6,7 +6,7 @@
# Overridable variables added to support building test .deb files
# as part of routine SCons builds. --SK
BUILDDEB_OPTIONS=
-PYTHON_VERSION=`python -V 2>&1| cut -d" " -f2 | cut -d"." -f0-2`
+PYTHON_VERSION=`python -V 2>&1| cut -d" " -f2 | cut -d"." -f1-2`
PYTHON_PATH=/usr/bin/python
PYTHON=$(PYTHON_PATH)$(PYTHON_VERSION)
#######
@@ -55,7 +55,7 @@ install: build
@########
mkdir -p debian/scons/usr/lib/python$(PYTHON_VERSION)/site-packages/
rm -rf debian/scons/usr/lib/python$(PYTHON_VERSION)/site-packages/SCons
- cp -r build/lib/SCons debian/scons/usr/lib/python$(PYTHON_VERSION)/site-packages/
+ cp -r build/lib*/SCons debian/scons/usr/lib/python$(PYTHON_VERSION)/site-packages/
mkdir -p debian/scons/usr/bin/
rm -f debian/scons/usr/bin/scons