summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSteven Knight <knight@baldmt.com>2003-08-20 17:00:00 +0000
committerSteven Knight <knight@baldmt.com>2003-08-20 17:00:00 +0000
commitb8ad44992b38ccbe31ab15d1f60d41b9d9e67c7c (patch)
treed86afbdaab7b2d22b7c4c04a7b410a0f97bc8791 /debian
parent1c0a7d503532ad8b1129192872d15a72c441ad28 (diff)
downloadscons-b8ad44992b38ccbe31ab15d1f60d41b9d9e67c7c.tar.gz
Build a Debian package, too.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog33
-rw-r--r--debian/control20
-rw-r--r--debian/dirs2
-rw-r--r--debian/postinst4
-rw-r--r--debian/rules14
5 files changed, 54 insertions, 19 deletions
diff --git a/debian/changelog b/debian/changelog
index 27097b87..fe292e1b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -2,7 +2,7 @@ scons (0.92-1) unstable; urgency=low
* Third beta release.
- -- Steven Knight <knight@baldmt.com> Tue Aug 19 19:05:23 CDT 2003
+ -- Steven Knight <knight@baldmt.com> Wed, 20 Aug 2003 03:45:28 -0500
scons (0.91-1) unstable; urgency=low
@@ -63,17 +63,40 @@ scons (0.09-1) unstable; urgency=low
scons (0.08-1) unstable; urgency=low
- * Second post-official-Debian build cycle
+ * New upstream release (Closes: #158373)
- -- Steven Knight <knight@baldmt.com> Mon, 15 Jul 2002 12:08:51 -0500
+ -- Moshe Zadka <moshez@debian.org> Mon, 21 Oct 2002 16:52:11 +0200
+scons (0.07-3) unstable; urgency=low
+
+ * Removing /usr/doc links
+ * Python 2.1 -> Python 2.2
+
+ -- Moshe Zadka <moshez@debian.org> Tue, 27 Aug 2002 18:48:02 +0300
+
+scons (0.07-2) unstable; urgency=low
+
+ * Ugh, who would put distutils.core in python-dev? Changing build
+ dependancies (Closes: #146601)
+ * While we're at it, update Standards-Version
+
+ -- Moshe Zadka <moshez@debian.org> Sat, 11 May 2002 08:25:07 +0300
scons (0.07-1) unstable; urgency=low
- * Folding uploaded Debian build into SCons source
+ * New upstream version
+ * Packaging properly, instead of as debian native
+ * Modifying copyright to include upstream location (Closes: #144491)
+ * Fixing my e-mail address (Closes: #144490)
+ * Thanks for looking after my packages, tbm ;-)
+
+ -- Moshe Zadka <moshez@debian.org> Sat, 4 May 2002 13:05:53 +0300
+
+scons (0.06-1) unstable; urgency=low
- -- Steven Knight <knight@baldmt.com> Thu, 2 May 2002 13:37:16 -0500
+ * New upstream version
+ -- Moshe Zadka <moshez@debian.org> Mon, 15 Apr 2002 19:22:09 +0300
scons (0.05-1) unstable; urgency=low
diff --git a/debian/control b/debian/control
index b5ecaff3..7e0d2a5f 100644
--- a/debian/control
+++ b/debian/control
@@ -2,12 +2,22 @@ Source: scons
Section: devel
Priority: optional
Maintainer: Moshe Zadka <moshez@debian.org>
-Build-Depends-Indep: debhelper (>> 2.0.0), python2.1
-Standards-Version: 3.2.1
+Build-Depends-Indep: debhelper (>> 2.0.0), python2.2-dev
+Standards-Version: 3.5.6
Package: scons
Architecture: all
-Depends: python2.1
+Depends: python2.2
Description: A replacement for Make
- Scons is able to build files from other files, based on the
- dependency DAG.
+ SCons is an Open Source software construction tool--that is, a build
+ tool; an improved substitute for the classic Make utility; a better
+ way to build software. SCons is based on the design which won the
+ Software Carpentry build tool design competition in August 2000. SCons
+ "configuration files" are Python scripts that call an API to establish
+ dependencies and specify how targets are built. SCons maintains a global
+ view of all dependencies in a tree, and can scan source (or other) files
+ for implicit dependencies, such as files specified on #include lines.
+ SCons uses MD5 signatures to rebuild only when the contents of a file
+ have really changed, not just when the timestamp has been touched.
+ SCons supports side-by-side variant builds, and is easily extended with
+ user-defined Builder and/or Scanner objects.
diff --git a/debian/dirs b/debian/dirs
index cb883638..47f84cfc 100644
--- a/debian/dirs
+++ b/debian/dirs
@@ -1,4 +1,4 @@
usr/bin
-usr/lib/python2.1/site-packages
+usr/lib/python2.2/site-packages
usr/share/doc/scons
usr/share/man/man1
diff --git a/debian/postinst b/debian/postinst
index 1e05a5df..6923e0f5 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -10,8 +10,8 @@ NAME=scons
case "$1" in
configure|abort-upgrade|abort-remove|abort-deconfigure)
dpkg --listfiles $NAME | grep '\.py$' | \
- xargs -n 1 /usr/bin/python -c 'import py_compile,sys;py_compile.compile(sys.argv[1])'
+ xargs -n 1 /usr/bin/python2.2 -c 'import py_compile,sys;py_compile.compile(sys.argv[1])'
dpkg --listfiles $NAME | grep '\.py$' | \
- xargs -n 1 /usr/bin/python -O -c 'import py_compile,sys;py_compile.compile(sys.argv[1])'
+ xargs -n 1 /usr/bin/python2.2 -O -c 'import py_compile,sys;py_compile.compile(sys.argv[1])'
;;
esac
diff --git a/debian/rules b/debian/rules
index e9e64217..4250539d 100644
--- a/debian/rules
+++ b/debian/rules
@@ -6,7 +6,7 @@
# Overridable variables added to support building test .deb files
# as part of routine SCons builds. --SK
BUILDDEB_OPTIONS=
-PYTHON=/usr/bin/python2.1
+PYTHON=/usr/bin/python2.2
#######
# Uncomment this to turn on verbose mode.
@@ -51,9 +51,9 @@ install: build
@# already exist on our non-Debian test build systems. Hence,
@# we do a lot of mkdir -p and rm -f here... --SK
@########
- mkdir -p debian/scons/usr/lib/python2.1/site-packages/
- rm -rf debian/scons/usr/lib/python2.1/site-packages/SCons
- cp -r build/lib/SCons debian/scons/usr/lib/python2.1/site-packages/
+ mkdir -p debian/scons/usr/lib/python2.2/site-packages/
+ rm -rf debian/scons/usr/lib/python2.2/site-packages/SCons
+ cp -r build/lib/SCons debian/scons/usr/lib/python2.2/site-packages/
mkdir -p debian/scons/usr/bin/
rm -f debian/scons/usr/bin/scons
@@ -62,8 +62,8 @@ ifeq ($(PYTHON),python)
cp build/scripts/scons debian/scons/usr/bin/scons
cp build/scripts/sconsign debian/scons/usr/bin/sconsign
else
- sed '1s|.*|#!/usr/bin/python2.1|' build/scripts/scons > debian/scons/usr/bin/scons
- sed '1s|.*|#!/usr/bin/python2.1|' build/scripts/sconsign > debian/scons/usr/bin/sconsign
+ sed '1s|.*|#!/usr/bin/python2.2|' build/scripts/scons > debian/scons/usr/bin/scons
+ sed '1s|.*|#!/usr/bin/python2.2|' build/scripts/sconsign > debian/scons/usr/bin/sconsign
endif
chmod +x debian/scons/usr/bin/scons
chmod +x debian/scons/usr/bin/sconsign
@@ -77,10 +77,12 @@ endif
mkdir -p debian/scons/usr/share/doc/scons
rm -f debian/scons/usr/share/doc/scons/changelog
rm -f debian/scons/usr/share/doc/scons/README.txt
+ rm -f debian/scons/usr/share/doc/scons/CHANGES.txt
rm -f debian/scons/usr/share/doc/scons/*.gz
rm -f debian/scons/usr/share/doc/scons/copyright
cp README.txt debian/scons/usr/share/doc/scons/
+ cp CHANGES.txt debian/scons/usr/share/doc/scons/
gzip -9 debian/scons/usr/share/doc/scons/*