summaryrefslogtreecommitdiff
path: root/gentoo
diff options
context:
space:
mode:
authorSteven Knight <knight@baldmt.com>2003-05-27 11:55:49 +0000
committerSteven Knight <knight@baldmt.com>2003-05-27 11:55:49 +0000
commitdd46e3d77cb07573d2ff1cb0caed60e5f474cc3c (patch)
tree7afc2577bcedf2a05d39da624ce5b3e14e6c72a1 /gentoo
parentb7f2dfccaae3d1a25a6114ad054bbc13492ecaec (diff)
downloadscons-dd46e3d77cb07573d2ff1cb0caed60e5f474cc3c.tar.gz
Generate our own copies of Gentoo files (.ebuild, and a digest record).
Diffstat (limited to 'gentoo')
-rw-r--r--gentoo/scons.ebuild.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/gentoo/scons.ebuild.in b/gentoo/scons.ebuild.in
new file mode 100644
index 00000000..36f83db4
--- /dev/null
+++ b/gentoo/scons.ebuild.in
@@ -0,0 +1,25 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $__NULL__Header: /home/cvsroot/gentoo-x86/dev-util/scons/scons-__VERSION__.ebuild,v 1.2 2003/02/13 12:00:11 vapier Exp __NULL__$
+
+MY_P=${PN}-__VERSION__
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Extensible python-based build utility"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.scons.org"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND=">=dev-lang/python-2.0"
+
+src_compile() {
+ python setup.py build
+}
+
+src_install () {
+ python setup.py install --root=${D}
+ dodoc *.txt PKG-INFO MANIFEST
+ doman scons.1
+}