summaryrefslogtreecommitdiff
path: root/src/setup.py
diff options
context:
space:
mode:
authorSteven Knight <knight@baldmt.com>2004-12-02 04:29:30 +0000
committerSteven Knight <knight@baldmt.com>2004-12-02 04:29:30 +0000
commit2fa621343311180c159ee09262cefe0ee0ad2d83 (patch)
tree16de7183a1894d8d9e1dfe73cbcb354f472f5f85 /src/setup.py
parent04f1a4d2dd431f169a7aed2ae740c8cbd09e8d50 (diff)
downloadscons-2fa621343311180c159ee09262cefe0ee0ad2d83.tar.gz
Scan SCons source code for uncaught KeyboardInterrupts. (Christoph Wiedemann)
Diffstat (limited to 'src/setup.py')
-rw-r--r--src/setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/setup.py b/src/setup.py
index 525d000d..d2b76c0c 100644
--- a/src/setup.py
+++ b/src/setup.py
@@ -164,9 +164,11 @@ class install_lib(_install_lib):
# ...and they didn't explicitly ask for the standard
# directory, so guess based on what's out there.
try:
- e = filter(lambda x: x[:6] == "scons-", os.listdir(prefix))
- except:
+ l = os.listdir(prefix)
+ except OSError:
e = None
+ else:
+ e = filter(lambda x: x[:6] == "scons-", l)
if e:
# We found a path name (e.g.) /usr/lib/scons-XXX,
# so pick the version-specific directory.