summaryrefslogtreecommitdiff
path: root/src/setup.py
diff options
context:
space:
mode:
authorWilliam Deegan <bill@baddogconsulting.com>2013-02-22 14:52:23 -0800
committerWilliam Deegan <bill@baddogconsulting.com>2013-02-22 14:52:23 -0800
commite8b5a3804ce29f7ec278cb72526f9c93a41a97ae (patch)
tree0ea93d25ee8b07dd6d957aa7b692259683900ff4 /src/setup.py
parent1063705ca2a089bb5094cfcf782c981fe34ce801 (diff)
downloadscons-e8b5a3804ce29f7ec278cb72526f9c93a41a97ae.tar.gz
improved comment around changed code
Diffstat (limited to 'src/setup.py')
-rw-r--r--src/setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/setup.py b/src/setup.py
index 8bf36bda..90373372 100644
--- a/src/setup.py
+++ b/src/setup.py
@@ -341,6 +341,7 @@ class install_scripts(_install_scripts):
# log.info("changing mode of %s", file)
pass
else:
+ # Use symbolic versions of permissions so this script doesn't fail to parse under python3.x
exec_and_read_permission = stat.S_IXOTH | stat.S_IXUSR | stat.S_IXGRP | stat.S_IROTH | stat.S_IRUSR | stat.S_IRGRP
mode_mask = 4095 # Octal 07777 used because python3 has different octal syntax than python 2
mode = ((os.stat(file)[stat.ST_MODE]) | exec_and_read_permission) & mode_mask