summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Lantinga <slouken@libsdl.org>2021-01-23 09:50:43 -0800
committerSam Lantinga <slouken@libsdl.org>2021-01-23 09:50:43 -0800
commitf292cc974e91d8ab02f6cabd86af963aec2bd702 (patch)
tree5e5e3e3ed65c8bddf5ef7d8250120c41b28bee06 /CMakeLists.txt
parent36a3ea9411157a369d0cffa1c8fadb1180419c07 (diff)
downloadsdl-f292cc974e91d8ab02f6cabd86af963aec2bd702.tar.gz
Fixed bug 5467 - SDL sys timer Mac OS update proposal
David Carlier Change of api from 2016 which reduce code complexity a bit.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 662658b3a..1b2e74c5f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -873,6 +873,7 @@ if(LIBC)
else()
set(HAVE_ALLOCA_H 1)
set(HAVE_ALLOCA 1)
+ check_symbol_exists(clock_gettime_nsec_np HAVE_CLOCK_GETTIME_NSEC_NP)
endif()
check_struct_has_member("struct sigaction" "sa_sigaction" "signal.h" HAVE_SA_SIGACTION)