summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Kubisiak <brian@kubisiak.com>2020-11-15 04:10:02 +0300
committerBrian Kubisiak <brian@kubisiak.com>2020-11-15 04:10:02 +0300
commit5fb149ea1e1869a9b4661ef2b66d723694ac1e77 (patch)
treedc69b898d6f6c6070f7e31706bceab07684dd23e /configure.ac
parentfbc352309562a1657bf4146adb265f77f03383e5 (diff)
downloadsdl-5fb149ea1e1869a9b4661ef2b66d723694ac1e77.tar.gz
egl: Fix detection in configure script on systems without X11 (bug #5270)
In recent versions of EGL headers on Linux, the MESA_EGL_NO_X11_HEADERS macro is deprecated and has been replaced with EGL_NO_X11. As a result, the configure script would fail the compilation check for EGL headers and disable EGL (and by extension, Wayland) support when X11 headers are not installed. Fix this by adding the correct macro to disable X11 support in the headers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 76393e607..0cd62a980 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2374,6 +2374,7 @@ CheckOpenGLESX11()
#define LINUX
#define EGL_API_FB
#define MESA_EGL_NO_X11_HEADERS
+ #define EGL_NO_X11
#include <EGL/egl.h>
#include <EGL/eglext.h>
],[