summaryrefslogtreecommitdiff
path: root/test/configure.in
diff options
context:
space:
mode:
authorSam Lantinga <slouken@libsdl.org>2012-01-08 02:23:37 -0500
committerSam Lantinga <slouken@libsdl.org>2012-01-08 02:23:37 -0500
commitc1782915e4c8b0900efd1aa2e854a2629203fa16 (patch)
treea6e0632ce35fc322887727aa5c54f4701fc093ca /test/configure.in
parent4f332a28391029f9986bdcbdb2fb0d1b68213b37 (diff)
downloadsdl-c1782915e4c8b0900efd1aa2e854a2629203fa16.tar.gz
Fixed bug 1242 - PATCH: Improve support for OpenGL ES under X11
Scott Percival 2011-07-03 06:41:51 PDT This submission is aimed at making life easier for OpenGL ES capable devices running a X11 stack (e.g. Maemo, Meego, TrimSlice, other ARM SoC boards not running Android). SDL's Pandora support already has the neccesary GLES-to-X11 glue code, however it's all ghetto'd off in Makefile.pandora and not very flexible. The patch: - adds an awesome --enable-video-opengles option to configure - re-modifies the opengles and opengles2 SDL_renderers to use function pointers - no idea why this was removed? - for SDL_Renderers, links in libGLESv1_CM, libGLES_CM (for PowerVR fans) or libGLESv2 at runtime - links in libEGL.so at runtime - the old code made an assumption that eglFunctions could be pulled from the active GLES library, PowerVR for one doesn't let you do that with their libGLESv2 - allows you to pick which of GLES v1 or v2 to load via SDL_GL_CONTEXT_MAJOR_VERSION So far I've tested this on a Nokia N900 (OMAP 3430/SGX 530 running Maemo 5) and a Toshiba AC100 (Tegra 2 running Ubuntu 10.10). I haven't tested it on... well, everything that isn't those two, such as a Pandora, iOS or Android device. The Pandora specific code should be kept intact (fingers crossed), and nothing painfully drastic has been added to the SDL_renderers. The library loading sequence in SDL_x11opengles has been updated to accomodate both NVIDIA's propensity to let developers get away with murder and PowerVR's alternative of punishing every missed step. The test apps work okay with GLES or GLES2 as the renderer. For some reason alpha blending doesn't seem to work on the Tegra 2; last week NVIDIA pushed out a new set of X11 GLES drivers, so I'll try and investigate once I upgrade those. Also, this patch adds things to configure.in, include/SDL_config.h.in and test/configure.in. I didn't know what the policy was re. committing generated spaghetti from autotools, so ./autogen.sh has to be run again. Sorry. I think that's about everything, let me know if there's anything I've overlooked.
Diffstat (limited to 'test/configure.in')
-rw-r--r--test/configure.in15
1 files changed, 7 insertions, 8 deletions
diff --git a/test/configure.in b/test/configure.in
index b24b6a6fe..a808d664a 100644
--- a/test/configure.in
+++ b/test/configure.in
@@ -103,12 +103,10 @@ dnl Check for OpenGL ES
AC_MSG_CHECKING(for OpenGL ES support)
have_opengles=no
AC_TRY_COMPILE([
- #if defined (__QNXNTO__)
- #include <GLES/gl.h>
- #elif defined (__IPHONEOS__)
+ #if defined (__IPHONEOS__)
#include <OpenGLES/ES1/gl.h>
#else
- #error "No OpenGL ES support"
+ #include <GLES/gl.h>
#endif /* __QNXNTO__ */
],[
],[
@@ -116,11 +114,12 @@ have_opengles=yes
])
AC_MSG_RESULT($have_opengles)
-if test x$have_opengl = xyes; then
- CFLAGS="$CFLAGS -DHAVE_OPENGL"
- GLLIB="$XPATH $SYS_GL_LIBS"
-elif test x$have_opengles = xyes; then
+GLLIB=""
+if test x$have_opengles = xyes; then
CFLAGS="$CFLAGS -DHAVE_OPENGLES"
+ GLLIB="$XPATH -lGLESv1_CM"
+elif test x$have_opengl = xyes; then
+ CFLAGS="$CFLAGS -DHAVE_OPENGL"
GLLIB="$XPATH $SYS_GL_LIBS"
else
GLLIB=""