summaryrefslogtreecommitdiff
path: root/sed/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sed/Makefile.am')
-rw-r--r--sed/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/sed/Makefile.am b/sed/Makefile.am
new file mode 100644
index 0000000..a164255
--- /dev/null
+++ b/sed/Makefile.am
@@ -0,0 +1,17 @@
+## Process this file with automake to produce Makefile.in
+bin_PROGRAMS = sed
+
+localedir = $(datadir)/locale
+
+sed_SOURCES = sed.c compile.c execute.c regexp.c fmt.c mbcs.c utils.c
+noinst_HEADERS = sed.h utils.h
+
+AM_CPPFLAGS = -I$(top_srcdir)/lib -I$(top_srcdir) -I$(top_builddir)/lib \
+ -DLOCALEDIR=\"$(localedir)\"
+
+sed_LDADD = ../lib/libsed.a @INTLLIBS@ @LIB_ACL@ @LIB_SELINUX@
+sed_DEPENDENCIES = ../lib/libsed.a
+
+$(PROGRAMS): $(LDADD)
+
+