summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaolo Bonzini <bonzini@gnu.org>2006-10-22 19:09:47 +0000
committerPaolo Bonzini <bonzini@gnu.org>2008-01-09 16:12:16 +0100
commitcba6413f07c39d757bafcfff411588e3c0631627 (patch)
treeaeac54bfe52b71d4c4f1d2f94541a26221aa84fe /Makefile.am
parentef5850a7c8248e53825b13589406043e338d8c2c (diff)
downloadsed-cba6413f07c39d757bafcfff411588e3c0631627.tar.gz
finish gnulib conversion -- upgrade bootstrap and a few detailsv4.1a
git-archimport-id: bonzini@gnu.org--2004b/sed--stable--4.1--patch-79
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 30943e4..394f729 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -11,7 +11,8 @@ SUBDIRS = intl lib po sed doc testsuite
noinst_DATA = bootstrap.sh
noinst_HEADERS = basicdefs.h
-EXTRA_DIST = BUGS THANKS COPYING.DOC README.boot config/texi2dvi config/help2man
+EXTRA_DIST = BUGS THANKS COPYING.DOC README.boot \
+ autoboot build-aux/texi2dvi build-aux/help2man
html:
cd doc && make html
@@ -25,11 +26,20 @@ dist-hook:
cp -p $(srcdir)/bootstrap.sh $(distdir)/bootstrap.sh
full-distcheck:
+ make distcheck EXTRA_DC_FLAGS='--enable-regex-tests'
make distcheck EXTRA_DC_FLAGS='--enable-html'
make distcheck EXTRA_DC_FLAGS='--disable-i18n'
make distcheck EXTRA_DC_FLAGS='--disable-nls'
- make distcheck EXTRA_DC_FLAGS='--without-included-regex'
make distcheck EXTRA_DC_FLAGS='--without-included-gettext'
+ @case "$(host)" in \
+ *-linux*|*-gnu*) \
+ echo make distcheck EXTRA_DC_FLAGS=\'--without-included-regex\'; \
+ make distcheck EXTRA_DC_FLAGS='--without-included-regex' \
+ ;; \
+ *) \
+ echo Skipping check --without-included-regex \
+ ;; \
+ esac
## update-regex:
## HOST=sources.redhat.com && \