summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSerge Hallyn <serge@hallyn.com>2016-07-30 23:28:48 -0500
committerSerge Hallyn <serge@hallyn.com>2016-07-30 23:29:49 -0500
commit5a6e0c0ebd4166f3df9b0b4c628705e5e3a05aa0 (patch)
treecc01d829df509da63b34f35b7fe9e1b8621165e2 /debian/rules
parentf9aecd19f3cc7c1389cbeb3c8e0e6f0679d745b7 (diff)
downloadshadow-5a6e0c0ebd4166f3df9b0b4c628705e5e3a05aa0.tar.gz
Merge upstream 4.3
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index 51c0f5de..1c56a077 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,6 +3,8 @@
DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+export DEB_BUILD_HARDENING=1
+
# Enable PIE, BINDNOW, and possible future flags.
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
@@ -19,7 +21,7 @@ DEB_DESTDIR=$(CURDIR)/debian/tmp
include /usr/share/cdbs/1/class/autotools.mk
# Adds extra options when calling the configure script:
-DEB_CONFIGURE_EXTRA_FLAGS := --disable-shared --without-libcrack --mandir=/usr/share/man --with-libpam --enable-shadowgrp --enable-man --disable-account-tools-setuid --with-group-name-max-length=32 --without-acl --without-attr --without-tcb
+DEB_CONFIGURE_EXTRA_FLAGS := --disable-shared --without-libcrack --mandir=/usr/share/man --with-libpam --enable-shadowgrp --enable-man --disable-account-tools-setuid --with-group-name-max-length=32 --without-acl --without-attr --without-tcb SHELL=/bin/sh
ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
DEB_CONFIGURE_EXTRA_FLAGS += --host=$(DEB_HOST_GNU_TYPE)
endif