summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSerge Hallyn <serge.hallyn@ubuntu.com>2016-09-18 22:14:43 -0500
committerSerge Hallyn <serge@hallyn.com>2016-10-13 10:19:55 -0500
commitd9e428fd63e49486c8fb0f2e03df7a5608b0b0e2 (patch)
treec42692274474b7a037c9c2ea24b793c2540c6a83 /debian/rules
parent68cd195044deb448c865d267499e1e4fd9322057 (diff)
parent3fcf082618704e4361653a2112cec97b8252a53e (diff)
downloadshadow-d9e428fd63e49486c8fb0f2e03df7a5608b0b0e2.tar.gz
Imported Debian patch 1:4.4-12016-10-13/d1
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules6
1 files changed, 3 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index 1c56a077..f170a74a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,10 +3,10 @@
DEB_HOST_ARCH_OS := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-export DEB_BUILD_HARDENING=1
-
# Enable PIE, BINDNOW, and possible future flags.
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
# Call autoreconf since we need to regenerate all the autofoo files
include /usr/share/cdbs/1/rules/autoreconf.mk
@@ -21,7 +21,7 @@ DEB_DESTDIR=$(CURDIR)/debian/tmp
include /usr/share/cdbs/1/class/autotools.mk
# Adds extra options when calling the configure script:
-DEB_CONFIGURE_EXTRA_FLAGS := --disable-shared --without-libcrack --mandir=/usr/share/man --with-libpam --enable-shadowgrp --enable-man --disable-account-tools-setuid --with-group-name-max-length=32 --without-acl --without-attr --without-tcb SHELL=/bin/sh
+DEB_CONFIGURE_EXTRA_FLAGS := --disable-shared --without-libcrack --mandir=/usr/share/man --with-libpam --enable-shadowgrp --enable-man --disable-account-tools-setuid --with-group-name-max-length=32 --without-acl --without-attr --without-tcb
ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
DEB_CONFIGURE_EXTRA_FLAGS += --host=$(DEB_HOST_GNU_TYPE)
endif