summaryrefslogtreecommitdiff
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorChristian Perrier <bubulle@debian.org>2013-07-27 18:42:08 +0200
committerChristian Perrier <bubulle@debian.org>2013-07-27 18:42:08 +0200
commitdb1dc7288b64873f4f39e8404fd99c1bf55c7a8b (patch)
tree10026e84c8b73d4e5ad6704ab1cb78ea7c63c305 /lib/Makefile.am
parent6d11fd0a58e3bc52763f121421b1c0ffe09d48be (diff)
downloadshadow-db1dc7288b64873f4f39e8404fd99c1bf55c7a8b.tar.gz
Imported Upstream version 4.1.5.1upstream/4.1.5.1
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am67
1 files changed, 67 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 00000000..c448dd30
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,67 @@
+
+AUTOMAKE_OPTIONS = 1.0 foreign
+
+DEFS =
+
+noinst_LTLIBRARIES = libshadow.la
+
+libshadow_la_LDFLAGS = -version-info 0:0:0
+
+libshadow_la_SOURCES = \
+ commonio.c \
+ commonio.h \
+ defines.h \
+ encrypt.c \
+ exitcodes.h \
+ faillog.h \
+ fields.c \
+ fputsx.c \
+ getdef.c \
+ getdef.h \
+ get_gid.c \
+ getlong.c \
+ get_pid.c \
+ get_uid.c \
+ getulong.c \
+ groupio.c \
+ groupmem.c \
+ groupio.h \
+ gshadow.c \
+ lockpw.c \
+ nscd.c \
+ nscd.h \
+ pam_defs.h \
+ port.c \
+ port.h \
+ prototypes.h \
+ pwauth.c \
+ pwauth.h \
+ pwio.c \
+ pwio.h \
+ pwmem.c \
+ selinux.c \
+ semanage.c \
+ sgetgrent.c \
+ sgetpwent.c \
+ sgetspent.c \
+ sgroupio.c \
+ sgroupio.h\
+ shadow.c \
+ shadowio.c \
+ shadowio.h \
+ shadowmem.c \
+ spawn.c \
+ utent.c
+
+if WITH_TCB
+libshadow_la_SOURCES += tcbfuncs.c tcbfuncs.h
+endif
+
+# These files are unneeded for some reason, listed in
+# order of appearance:
+#
+# sources for dbm support (not yet used)
+
+EXTRA_DIST = \
+ .indent.pro \
+ gshadow_.h