summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMurray Cumming <murrayc@murrayc.com>2016-04-20 10:43:17 +0200
committerMurray Cumming <murrayc@murrayc.com>2016-04-20 11:45:35 +0200
commit120913157306829fd604ad0c0103ac590bd2b364 (patch)
tree65baec07fab83bac06cd291e7fd10ec096c91b62 /configure.ac
parent0433b5eb36c906310a910c5bfc652cee3c4bbda0 (diff)
downloadsigc++-120913157306829fd604ad0c0103ac590bd2b364.tar.gz
benchmark: Use boost::timer instead of Glib::Timer.
And optionally build it, when --enable-benchmark is passed to configure.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb421c5..b09af78 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,6 +56,22 @@ MM_ARG_ENABLE_WARNINGS([SIGC_WXXFLAGS],
# Offer the ability to omit some API from the library.
MM_ARG_DISABLE_DEPRECATED_API([SIGCXX])
+AC_ARG_ENABLE(benchmark,
+ AS_HELP_STRING([--enable-benchmark=yes|no]),
+ [enable_benchmark=yes]
+)
+
+AM_CONDITIONAL([SIGC_BUILD_BENCHMARK], [test "x$enable_benchmark" = xyes])
+
+AS_IF([test "x$enable_benchmark" = xyes],[
+ #Use boost::timer for our benchmark, if it's available.
+ # See http://www.gnu.org/software/autoconf-archive/ax_boost_base.html
+ # Boost System is needed by Boost Timer
+ AX_BOOST_BASE
+ AX_BOOST_SYSTEM
+ AX_BOOST_TIMER
+])
+
AC_CONFIG_FILES([Makefile
${SIGCXX_MODULE_NAME}.pc:sigc++.pc.in
${SIGCXX_MODULE_NAME}-uninstalled.pc:sigc++-uninstalled.pc.in