summaryrefslogtreecommitdiff
path: root/tests/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/meson.build')
-rw-r--r--tests/meson.build9
1 files changed, 6 insertions, 3 deletions
diff --git a/tests/meson.build b/tests/meson.build
index 87605a4..e0f57d7 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -1,6 +1,6 @@
# tests
-# input: sigcxx_own_dep, do_benchmark, can_benchmark, benchmark_dep
+# input: sigcxx_own_dep, build_tests, do_benchmark, can_benchmark, benchmark_dep
benchmark_timeout = 100
@@ -67,10 +67,13 @@ foreach ex : test_programs
exe_file = executable(ex_name, ex_sources,
dependencies: sigcxx_own_dep,
implicit_include_directories: false,
- build_by_default: true
+ build_by_default: build_tests,
)
- test(ex_name, exe_file)
+ # If exe_file is a test program, it is built by default unconditionally.
+ if build_tests
+ test(ex_name, exe_file)
+ endif
endforeach
if can_benchmark