summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2013-01-03 11:30:56 -0800
committerBob Ippolito <bob@redivi.com>2013-01-03 11:30:56 -0800
commit88186b0b91343fed6d22e45b940ebd7f7e58f703 (patch)
treefc152a4214b46113a3b04891d89619833be753d3 /setup.py
parentbad35638105e9adc4f802c2dd515790646bb01a8 (diff)
downloadsimplejson-88186b0b91343fed6d22e45b940ebd7f7e58f703.tar.gz
bump to v3.0.5, fix deprecations in testsv3.0.5
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 9 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index e61bac3..607e7bc 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,5 @@
#!/usr/bin/env python
+from __future__ import with_statement
import sys
from distutils.core import setup, Extension, Command
@@ -7,9 +8,11 @@ from distutils.errors import CCompilerError, DistutilsExecError, \
DistutilsPlatformError
IS_PYPY = hasattr(sys, 'pypy_translation_info')
-VERSION = '3.0.4'
+VERSION = '3.0.5'
DESCRIPTION = "Simple, fast, extensible JSON encoder/decoder for Python"
-LONG_DESCRIPTION = open('README.rst', 'r').read()
+
+with open('README.rst', 'r') as f:
+ LONG_DESCRIPTION = f.read()
CLASSIFIERS = filter(None, map(str.strip,
"""
@@ -67,7 +70,10 @@ class TestCommand(Command):
def run(self):
import sys, subprocess
raise SystemExit(
- subprocess.call([sys.executable, 'simplejson/tests/__init__.py']))
+ subprocess.call([sys.executable,
+ # Turn on deprecation warnings
+ '-Wd',
+ 'simplejson/tests/__init__.py']))
def run_setup(with_binary):
cmdclass = dict(test=TestCommand)