summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2011-04-12 11:33:35 -0700
committerBob Ippolito <bob@redivi.com>2011-04-12 11:33:35 -0700
commitb84a573407e8acb05cb3a973da65c4ae28bd3daa (patch)
tree496e9ad86ecc7919b9298d839d0c20cb05ed0c1c /setup.py
parent5cad556f7d60a84eda51adca054c51a192c98c09 (diff)
downloadsimplejson-b84a573407e8acb05cb3a973da65c4ae28bd3daa.tar.gz
do not try to build extension under PyPy
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c61f5d2..bf38479 100644
--- a/setup.py
+++ b/setup.py
@@ -12,6 +12,7 @@ from distutils.command.build_ext import build_ext
from distutils.errors import CCompilerError, DistutilsExecError, \
DistutilsPlatformError
+IS_PYPY = hasattr(sys, 'pypy_translation_info')
VERSION = '2.1.4'
DESCRIPTION = "Simple, fast, extensible JSON encoder/decoder for Python"
LONG_DESCRIPTION = open('README.rst', 'r').read()
@@ -84,7 +85,7 @@ def run_setup(with_binary):
)
try:
- run_setup(True)
+ run_setup(not IS_PYPY)
except BuildFailed:
BUILD_EXT_WARNING = "WARNING: The C extension could not be compiled, speedups are not enabled."
print '*' * 75