summaryrefslogtreecommitdiff
path: root/src/components/smart_objects/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/components/smart_objects/CMakeLists.txt')
-rw-r--r--src/components/smart_objects/CMakeLists.txt65
1 files changed, 51 insertions, 14 deletions
diff --git a/src/components/smart_objects/CMakeLists.txt b/src/components/smart_objects/CMakeLists.txt
index 89f0dbdce..c1d599db6 100644
--- a/src/components/smart_objects/CMakeLists.txt
+++ b/src/components/smart_objects/CMakeLists.txt
@@ -1,21 +1,54 @@
+# Copyright (c) 2014, Ford Motor Company
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+#
+# Redistributions of source code must retain the above copyright notice, this
+# list of conditions and the following disclaimer.
+#
+# Redistributions in binary form must reproduce the above copyright notice,
+# this list of conditions and the following
+# disclaimer in the documentation and/or other materials provided with the
+# distribution.
+#
+# Neither the name of the Ford Motor Company nor the names of its contributors
+# may be used to endorse or promote products derived from this software
+# without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+# ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE
+# LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+# CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+# SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+# CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+# POSSIBILITY OF SUCH DAMAGE.
+
+
+set(SMART_OBJECTS_SRC_DIR ${COMPONENTS_DIR}/smart_objects/src)
+
include_directories (
- ./include
- ../utils/include/
+ include
+ ${COMPONENTS_DIR}/utils/include/
)
set (SOURCES
- ./src/smart_object.cc
- ./src/smart_schema.cc
- ./src/schema_item.cc
- ./src/always_false_schema_item.cc
- ./src/always_true_schema_item.cc
- ./src/default_shema_item.cc
- ./src/bool_schema_item.cc
- ./src/number_schema_item.cc
- ./src/enum_schema_item.cc
- ./src/string_schema_item.cc
- ./src/object_schema_item.cc
- ./src/array_schema_item.cc
+ ${SMART_OBJECTS_SRC_DIR}/smart_object.cc
+ ${SMART_OBJECTS_SRC_DIR}/smart_schema.cc
+ ${SMART_OBJECTS_SRC_DIR}/schema_item.cc
+ ${SMART_OBJECTS_SRC_DIR}/always_false_schema_item.cc
+ ${SMART_OBJECTS_SRC_DIR}/always_true_schema_item.cc
+ ${SMART_OBJECTS_SRC_DIR}/default_shema_item.cc
+ ${SMART_OBJECTS_SRC_DIR}/bool_schema_item.cc
+ ${SMART_OBJECTS_SRC_DIR}/number_schema_item.cc
+ ${SMART_OBJECTS_SRC_DIR}/enum_schema_item.cc
+ ${SMART_OBJECTS_SRC_DIR}/string_schema_item.cc
+ ${SMART_OBJECTS_SRC_DIR}/object_schema_item.cc
+ ${SMART_OBJECTS_SRC_DIR}/array_schema_item.cc
)
add_library("SmartObjects" ${SOURCES})
@@ -24,3 +57,7 @@ if(ENABLE_LOG)
target_link_libraries("SmartObjects" log4cxx -L${LOG4CXX_LIBS_DIRECTORY})
endif()
+if(BUILD_TESTS)
+ add_subdirectory(test)
+endif()
+