summaryrefslogtreecommitdiff
path: root/tools/intergen/third_party/pugixml/scripts/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tools/intergen/third_party/pugixml/scripts/CMakeLists.txt')
-rw-r--r--tools/intergen/third_party/pugixml/scripts/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/tools/intergen/third_party/pugixml/scripts/CMakeLists.txt b/tools/intergen/third_party/pugixml/scripts/CMakeLists.txt
new file mode 100644
index 000000000..c17596703
--- /dev/null
+++ b/tools/intergen/third_party/pugixml/scripts/CMakeLists.txt
@@ -0,0 +1,18 @@
+project(pugixml)
+
+cmake_minimum_required(VERSION 2.6)
+set(BUILD_SHARED_LIBS OFF CACHE BOOL "Build shared instead of static library")
+
+set(HEADERS ../src/pugixml.hpp ../src/pugiconfig.hpp)
+set(SOURCES ${HEADERS} ../src/pugixml.cpp)
+
+if(BUILD_SHARED_LIBS)
+ add_library(pugixml SHARED ${SOURCES})
+else()
+ add_library(pugixml STATIC ${SOURCES})
+endif()
+
+set_target_properties(pugixml PROPERTIES VERSION 1.2 SOVERSION 1.2)
+
+install(TARGETS pugixml LIBRARY DESTINATION lib ARCHIVE DESTINATION lib)
+install(FILES ${HEADERS} DESTINATION include)