summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander Kutsan <akutsan@luxoft.com>2017-08-10 14:07:07 +0300
committerAndrey Oleynik <aoleynik@luxoft.com>2017-08-16 22:32:33 +0300
commit06729e8b744374a4d9694f669101b6c554ce42e0 (patch)
tree7fd73e4e64a831755fa02bbbd8ee8ccfb8f09efd /CMakeLists.txt
parent41fe2979a5f1f8a13428ae4fe88f37ee9824c92e (diff)
downloadsdl_core-06729e8b744374a4d9694f669101b6c554ce42e0.tar.gz
Arhitecture changes for support RC plugin
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 18 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6a62aed45c..b8fd497a09 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,7 +52,7 @@ option(ENABLE_GCOV "gcov code coverage feature" OFF)
option(ENABLE_SANITIZE "Sanitize tool" OFF)
option(ENABLE_SECURITY "Security Ford protocol protection" ON)
option(ENABLE_HMI_PTU_DECRYPTION "Policy table update parsed by hmi" ON)
-option(ENABLE_EXTENDED_POLICY "Turns extended flow which requires embedded system interaction" ON)
+option(REMOTE_CONTROL "Enable Reverse functionality" ON)
option(USE_COTIRE "Use Cotire to speed up build (currently only for commands tests)" ON)
option(USE_GOLD_LD "Use gold linker intead of GNU linker" ON)
option(USE_CCACHE "Turn on ccache usage" ON)
@@ -160,6 +160,11 @@ if (OS_TYPE_OPTION)
endif()
endif()
+if (REMOTE_CONTROL)
+ add_definitions(-DSDL_REMOTE_CONTROL)
+ message(STATUS "Remote control support is enabled (aka Reverse SDL or SDL-RC)")
+endif()
+
#Jenkins integration section end
add_custom_target(pasa-tarball
@@ -409,6 +414,18 @@ if(CMAKE_SYSTEM_NAME STREQUAL "QNX")
set(RTLIB )
endif()
+SET(RPATH_DIRECTORIES
+ ${CMAKE_INSTALL_PREFIX}/bin/plugins
+ /usr/local/lib
+ /usr/local
+ ${CMAKE_INSTALL_PREFIX}/bin
+)
+SET(CMAKE_SKIP_BUILD_RPATH FALSE)
+SET(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
+SET(CMAKE_INSTALL_RPATH "${RPATH_DIRECTORIES}")
+SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
+
+
# Building tests
if(BUILD_TESTS)
enable_testing()