summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexander <AKutsan@luxoft.com>2016-04-08 10:44:31 +0300
committerAlexander <AKutsan@luxoft.com>2016-04-21 15:03:10 +0300
commit0c3a71a7cc8437ec6fd6a8fc9c9f7ba02eec6b4c (patch)
tree828fc8798e336e02f1072ba70cb2a2367b4ffcb7 /CMakeLists.txt
parentbbe5e332c7a9147725b79a9914e7b02c30895fdc (diff)
downloadsdl_core-0c3a71a7cc8437ec6fd6a8fc9c9f7ba02eec6b4c.tar.gz
Use compiler from environment variables
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bc57be20a1..3e2aa24166 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,6 +63,9 @@ set(SECURITY_OPTION "$ENV{SECURITY_MODE}")
set(COMPONENTS_DIR ${CMAKE_SOURCE_DIR}/src/components)
set(SNAPSHOT_TAG "$ENV{SNAPSHOT_TAG}")
+set(CMAKE_CXX_COMPILER $ENV{CMAKE_CXX_COMPILER})
+set(CMAKE_C_COMPILER $ENV{CMAKE_C_COMPILER})
+
if (ARCH_TYPE_OPTION)
if (NOT (${ARCH_TYPE_OPTION} STREQUAL "x86") AND NOT (${ARCH_TYPE_OPTION} STREQUAL "armv7"))
message(AUTHOR_WARNING "HW architecture is not defined, using x86. Allowed values are x86/armv7 (case sensitive)")