summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJack Byrne <jack@livio.io>2015-07-28 13:52:34 -0400
committerJack Byrne <jack@livio.io>2015-07-28 13:52:34 -0400
commit11687835d071d211ed9e57272fa28711c74be3b6 (patch)
tree25274036dc9f1528bc5f39c0d8f0d200f3ae4764 /CMakeLists.txt
parent6d4237ccd3609ddf13fe629dbe1755455ab6f92b (diff)
downloadsdl_core-11687835d071d211ed9e57272fa28711c74be3b6.tar.gz
Added ifdefs for enabling/disabling PTU decryption by HMI
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 40feb61eb0..ffea5a2c3f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,6 +48,7 @@ option(ENABLE_LOG "Logging feature" ON)
option(ENABLE_GCOV "gcov code coverage feature" OFF)
option(ENABLE_SANITIZE "Sanitize tool" OFF)
option(ENABLE_SECURITY "Security Ford protocol protection" ON)
+option(ENABLE_HMI_PTU_DECRYPTION "Policy table update parsed by hmi" OFF)
set(OS_TYPE_OPTION "$ENV{OS_TYPE}")
set(DEBUG_OPTION "$ENV{DEBUG}")
@@ -238,6 +239,7 @@ pkg_check_modules(GLIB2 REQUIRED glib-2.0)
add_definitions(${GLIB2_CFLAGS})
endif()
+
# --- Interface generator
find_package(PythonInterp)
@@ -618,6 +620,11 @@ if(ENABLE_SECURITY)
#set(SecurityManagerTestIncludeDir ${CMAKE_SOURCE_DIR}/test/components/security_manager/include)
endif()
+if(ENABLE_HMI_PTU_DECRYPTION)
+ MESSAGE("USE DHMI_PTU_PARSER")
+ add_definitions(-DUSE_HMI_PTU_DECRYPTION)
+endif()
+
set(RTLIB rt)
if(CMAKE_SYSTEM_NAME STREQUAL "QNX")
set(RTLIB )