summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKozoriz <kozorizandriy@gmail.com>2016-03-10 10:59:30 +0200
committerKozoriz <kozorizandriy@gmail.com>2016-03-10 13:28:45 +0200
commit253f9a224e8e78182b3e5f26c422002a3b581c2c (patch)
tree8cc3351651158b71eb374ec734171df947b131fb /CMakeLists.txt
parent358ca6459aa2e9b2fe9ace737cc396937311c014 (diff)
downloadsdl_core-253f9a224e8e78182b3e5f26c422002a3b581c2c.tar.gz
TimeTester refatctoring.
Removed singletone using from TimeTester. TimeTester renamed -> TelemetryMonitor. All files and directories corrected. Tests corrected, all works. Disabled 2 tests(task created). Related to : APPLINK-21915
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b265c8a076..bc57be20a1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -42,7 +42,7 @@ option(BUILD_BT_SUPPORT "Bluetooth support" ON)
option(BUILD_USB_SUPPORT "libusb support" ON)
option(BUILD_BACKTRACE_SUPPORT "backtrace support" ON)
option(BUILD_TESTS "Possibility to build and run tests" OFF)
-option(TIME_TESTER "Enable profiling time test util" ON)
+option(TELEMETRY_MONITOR "Enable profiling time test util" ON)
option(ENABLE_LOG "Logging feature" ON)
option(ENABLE_GCOV "gcov code coverage feature" OFF)
option(ENABLE_SANITIZE "Sanitize tool" OFF)
@@ -222,8 +222,8 @@ if(ENABLE_LOG)
set(install-3rd_party_logger "install-3rd_party_logger")
endif()
-if (TIME_TESTER)
- add_definitions(-DTIME_TESTER)
+if (TELEMETRY_MONITOR)
+ add_definitions(-DTELEMETRY_MONITOR)
endif()
# TODO(AK): check current OS here