summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoragaliuzov <agaliuzov@luxoft.com>2016-05-16 00:12:12 -0700
committeragaliuzov <agaliuzov@luxoft.com>2016-05-16 01:45:41 -0700
commit59c5e55149cfe84367e3e3475eb1b090c3dd6402 (patch)
treecb0efd4c41bb3db0e4d93af2f3c5914ebc16a793 /CMakeLists.txt
parent793155c8d67254aa92fadb8a972476484c214b22 (diff)
parent2b17b5546d4d94665a37697d73f10adfb14b6dd3 (diff)
downloadsdl_core-59c5e55149cfe84367e3e3475eb1b090c3dd6402.tar.gz
Merge remote-tracking branch 'upstream/master' into develop
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3e2aa24166..3d7dde3076 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -48,6 +48,7 @@ option(ENABLE_GCOV "gcov code coverage feature" OFF)
option(ENABLE_SANITIZE "Sanitize tool" OFF)
option(ENABLE_SECURITY "Security Ford protocol protection" ON)
option(ENABLE_HMI_PTU_DECRYPTION "Policy table update parsed by hmi" ON)
+option(ENABLE_EXTENDED_POLICY "Turns extended flow which requires embedded system interaction" OFF)
set(OS_TYPE_OPTION "$ENV{OS_TYPE}")
set(DEBUG_OPTION "$ENV{DEBUG}")
@@ -229,6 +230,10 @@ if (TELEMETRY_MONITOR)
add_definitions(-DTELEMETRY_MONITOR)
endif()
+if (ENABLE_EXTENDED_POLICY)
+ add_definitions(-DEXTENDED_POLICY)
+endif()
+
# TODO(AK): check current OS here
add_definitions(-DOS_POSIX)