summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrey Oleynik <aoleynik@luxoft.com>2016-04-05 10:42:48 +0300
committerAndrey Oleynik <aoleynik@luxoft.com>2016-04-11 09:43:54 +0300
commit5a359c6f1292cebd610eaf0fc170e1aa3894b31b (patch)
tree7cc91bf25e31e3c59a164b66f9125f1e2a2d8285 /CMakeLists.txt
parent6808a52562978f1e01899573d77b47ad33dccff3 (diff)
downloadsdl_core-5a359c6f1292cebd610eaf0fc170e1aa3894b31b.tar.gz
Adds extended policy flag to CMake
Implements: APPLINK-22313
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b5cf7d1186..1d63531e75 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -49,6 +49,7 @@ option(ENABLE_GCOV "gcov code coverage feature" OFF)
option(ENABLE_SANITIZE "Sanitize tool" OFF)
option(ENABLE_SECURITY "Security Ford protocol protection" ON)
option(ENABLE_HMI_PTU_DECRYPTION "Policy table update parsed by hmi" ON)
+option(ENABLE_EXTENDED_POLICY "Turns extended flow which requires embedded system interaction" OFF)
set(OS_TYPE_OPTION "$ENV{OS_TYPE}")
set(DEBUG_OPTION "$ENV{DEBUG}")
@@ -228,6 +229,10 @@ if (TIME_TESTER)
add_definitions(-DTIME_TESTER)
endif()
+if (ENABLE_EXTENDED_POLICY)
+ add_definitions(-DEXTENDED_POLICY)
+endif()
+
# TODO(AK): check current OS here
add_definitions(-DOS_POSIX)