summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Kutsan <akutsan@luxoft.com>2017-03-03 11:32:09 +0200
committerJacob Keeler <jacob.keeler@livioradio.com>2017-05-16 10:09:53 -0400
commit5a70594cbc053230d8132516ac99339768e4a664 (patch)
tree38793dc301135e4a1fe9bb780c1e2dc0d4324400 /CMakeLists.txt
parentd3a44111f88bbe41f7c35944f19b4eafe4dfd6bb (diff)
downloadsdl_core-5a70594cbc053230d8132516ac99339768e4a664.tar.gz
Set Debug as default build
In case if CMAKE_BUILD_TYPE didn't set, set CMAKE_BUILD_TYPE=Debug Note: Cotire incorrectly create united file in case if CMAKE_BUILD_TYPE is empty
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 07dd4e8bea..a813b98a1c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,7 +65,6 @@ if(EXTENDED_POLICY STREQUAL "")
endif()
set(OS_TYPE_OPTION "$ENV{OS_TYPE}")
-set(DEBUG_OPTION "$ENV{DEBUG}")
set(HMI_TYPE_OPTION "$ENV{HMI_TYPE}")
set(TARGET_OPTION "$ENV{TARGET}")
set(MEDIA_MODE_OPTION "$ENV{MEDIA_MODE}")
@@ -110,11 +109,8 @@ if (MEDIA_MODE_OPTION)
endif()
endif()
-if (DEBUG_OPTION)
- if (${DEBUG_OPTION} STREQUAL "DBG_OFF")
- message(STATUS "Jenkins integration: build release version")
- set(CMAKE_BUILD_TYPE "Release" CACHE STRING "" FORCE)
- endif()
+if( NOT CMAKE_BUILD_TYPE )
+ set(CMAKE_BUILD_TYPE Debug CACHE STRING "Choose the type of build. Options are: None, Debug, Release, RelWithDebInfo, MinSizeRel." FORCE)
endif()
if (HMI_ADAPTER_OPTION)