summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorIra Lytvynenko (GitHub) <ILytvynenko@luxoft.com>2018-05-29 14:05:34 +0300
committerIra Lytvynenko (GitHub) <ILytvynenko@luxoft.com>2018-06-26 12:01:47 +0300
commit73e756b65d60a606253e8a24a2f1a0c909882158 (patch)
tree6b0742374f6153115f57706423537760c5b22e00 /CMakeLists.txt
parent738e4845aeb86ff784814790c312414fccba3338 (diff)
downloadsdl_core-73e756b65d60a606253e8a24a2f1a0c909882158.tar.gz
Remove remote control flag
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 1 insertions, 13 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 49959597a9..97bda27c53 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -51,7 +51,6 @@ option(ENABLE_GCOV "gcov code coverage feature" OFF)
option(ENABLE_SANITIZE "Sanitize tool" OFF)
option(ENABLE_SECURITY "Security Ford protocol protection" ON)
option(ENABLE_HMI_PTU_DECRYPTION "Policy table update parsed by hmi" ON)
-option(REMOTE_CONTROL "Enable Reverse functionality" ON)
option(USE_COTIRE "Use Cotire to speed up build (currently only for commands tests)" ON)
option(USE_GOLD_LD "Use gold linker intead of GNU linker" ON)
option(USE_CCACHE "Turn on ccache usage" ON)
@@ -156,11 +155,6 @@ if (OS_TYPE_OPTION)
endif()
endif()
-if (REMOTE_CONTROL)
- add_definitions(-DSDL_REMOTE_CONTROL)
- message(STATUS "Remote control support is enabled (aka Reverse SDL or SDL-RC)")
-endif()
-
#Jenkins integration section end
#Deliver Build Configuration
@@ -174,12 +168,6 @@ get_property(cValue CACHE EXTENDED_POLICY PROPERTY VALUE)
file(APPEND "${build_config_path}" "//${cHelpString}\n")
file(APPEND "${build_config_path}" "EXTENDED_POLICY:${cType}=${cValue}\n\n")
-get_property(cHelpString CACHE REMOTE_CONTROL PROPERTY HELPSTRING)
-get_property(cType CACHE REMOTE_CONTROL PROPERTY TYPE)
-get_property(cValue CACHE REMOTE_CONTROL PROPERTY VALUE)
-file(APPEND "${build_config_path}" "//${cHelpString}\n")
-file(APPEND "${build_config_path}" "REMOTE_CONTROL:${cType}=${cValue}\n\n")
-
get_property(cHelpString CACHE BUILD_BT_SUPPORT PROPERTY HELPSTRING)
get_property(cType CACHE BUILD_BT_SUPPORT PROPERTY TYPE)
get_property(cValue CACHE BUILD_BT_SUPPORT PROPERTY VALUE)
@@ -503,4 +491,4 @@ find_package(Doxygen)
message(STATUS "sudo apt-get install doxygen graphviz")
message(STATUS "To enable processing of MscGen comments please install mscgen")
message(STATUS "sudo apt-get install mscgen")
-endif() \ No newline at end of file
+endif()